Unstoppable x Brave Guide

.crypto is now live in Brave

Resolve .crypto websites on Desktop and Android using Brave Browser. (iOS to be announced soon).

How to set Brave up to resolve .crypto domains?

Let’s start with downloading the latest version of Brave. You can find it here.

Proceed with the installation and after that, let’s open Brave.

Once you open your Brave browser, enter a .crypto domain to the search bar.
If you don’t know any .crypto domain yet, we can recommend you to visit:

  • cryptofinally.crypto

  • kyber.crypto

  • myetherwallet.crypto

You will be asked to “Enable support of Unstoppable Domains in Brave.”

Brave’s approach at launch will use the DNS over HTTPS (DoH) technology, developed by Cloudflare.

After you click on Proceed using Cloudflare Server, all .crypto domains with an IPFS website will start loading on your Brave Browser, without any further configuration.

If for any reason you clicked on Disable, and you would like to enable it again, you simply need to go to your Brave Settings → Extensions → Method to resolve Unstoppable Domains, and select the option DNS over HTTPS, as shown in the following screenshot:

I enabled the the Brave extension when prompted and double checked my settings. But when I browse to a .crypto domain, something about my Verizon FIOS setup gets in the way. I get redirected to searchassist-dot-verizon-dot-com (newbie here and I’m not allowed to put URLs in my post yet) with a message that the .crypto domain cannot be found. I tried it with several examples (pomp.crypto, etc)

Hi
Can you please send us an email to support@unstoppabledomains.com?
Ideally if you could add screenshot of the Brave Settings as shown in the last image of this guide and a video recording your screen so we can take a look at all the redirections and URLs you are being sent.
We will try to find what may be the reason of the issue you are facing and get back to you.

I sent screenshots of the settings and output from the Redirect Path extension to support. Thanks.

1 Like